Official Community Forums
 
HomeHome  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  The Wiki  Website  github Project  

Share | 
 

 Does Server Version 1.5 actually work on WinXP? YES. Connected

View previous topic View next topic Go down 
AuthorMessage
Guest
Guest



PostSubject: Does Server Version 1.5 actually work on WinXP? YES. Connected   Thu 19 Jul - 16:11

I've tried everything I can think of to get this running on WinXP. Can't say I believe it does.

There must be some big caveat that isn't mentioned anywhere. Something not in the wiki. Some
Python conflict or Java or jdk6 issue, a bug not mentioned anywhere. A note that currently the
WinXP build is broken, anything.

I would love to see a screen shot along with the working multiverse.properties
and start-multiverse.bat or multiverse.sh.

It works on XP? Really? I am finding it hard to believe it is this difficult to get this thing up and running.

Setting a few default paths is one thing, hardcoding a filepath is no problem. Modding a few lines in
a shell script? Not difficult. Nothing however seems to move this forward for me. Same results on 2 different
PCs.

Following the wiki doesn't seem to work.

I have had the same results on two boxes with stock binaries and startup scripts.
Both have had more than one *perfectly* clean Java6 jre and jdk installs. Tried every path, backslash,
forward slash, cygpath and environment var or setting I can think of and not even close.

Hardcoded every thing that I could find in multiverse.properties, start-multiverse.bat,
startup_instance.py, under cygwin and multiverse.sh., cygwin recommended changes to
line 2 in prop2sh.awk, the path to sampleworld.mvw of course and lots more.



Been all over the wiki and google of course including, but not limited to:
http://www.multiversemmo.com/wiki/Platform_Tutorial_Getting_Started#JDBC_Driver_JAR_File_Setting
http://www.multiversemmo.com/wiki/Server_Troubleshooting#Problems_connecting_to_the_servers
http://www.multiversemmo.com/wiki/World_Instancing
http://www.multiversemmo.com/wiki/Server_Logging
http://update.multiverse.net/wiki/index.php/Understanding_the_Multiverse_Servers
http://www.multiversemmo.com/wiki/Running_the_Servers#Debugging_startup_errors



My other thread is here:

http://multiverse.forumotion.co.uk/t220-server-startup-failed-nothing-seems-to-work


Does Server Version 1.5 work on WinXP and jre and jdk 6 ? Evil or Very Mad




Last edited by Koron on Sun 22 Jul - 19:49; edited 5 times in total
Back to top Go down
Guest
Guest



PostSubject: Finally!   Sat 21 Jul - 11:28

"DONE INITIALIZING, you can log in now"

Ok, I guess I believe. Still haven't tried connecting yet.

At least server v1.5 runs on WinXP under Cygwin.

Had to make a couple of mods to multiverse.sh
such as hardcoding AGENT_NAME="wmgr_1" and AGENT_NAME="proxy_1" in start_proxy
and start_world_manager. That takes care of borked .pid and .out filenames and the log4j error.

"log4j:ERROR setFile(null,true) call failed.
.out (The filename, directory name, or volume label syntax is incorrect)"


The function alloc_domain_name in multiverse.sh seems to return Ok, doesn't exit 1.
So...anyone know why this line in multiverse.sh might be failing?
AGENT_NAME=$(alloc_domain_name AGENT ${AGENT_TYPE}_# )



Original thread
http://multiverse.forumotion.co.uk/t220-server-startup-failed-nothing-seems-to-work
Back to top Go down
Guest
Guest



PostSubject: Finally connected and killed a wolf.   Sun 22 Jul - 18:17

Finally started the servers, connected locally with the client and killed a wolf. cheers

Under Cygwin 1.7.5 on WinXP
jre and jdk6
MySQL 5.5
mysql-connector-java-3.1.14


Finally got the servers running without log file errors and connected on WinXP


First: Read the Platform tutorial
http://www.multiversemmo.com/wiki/Platform_Tutorial_Getting_Started


Client
multiverseclient.exe --development --noupdate

World Settings File
The world_settings_sample.xml should be in Multiverse Client\worlds install dir
Rename, mod and copy the world settings file as noted here:
http://www.multiversemmo.com/wiki/World_Settings_File_Reference#Working_offline

In addition to the changes noted in the Platform tutorial I made the changes below.

Mods to scripts and startup_instance.py

In multiverse.properties
Code:
### If multiverse.mvwfile property is not specified, it defaults to MV_HOME/config/worldname/worldname.mvw
### Example below is Windows path; On Linux/Unix, use forward slashes instead of double backslashes.
multiverse.worldname=sampleworld
###multiverse.mvwfile=c:\\multiverse\\config\\sampleworld\\sampleworld.mvw
multiverse.mvwfile=c:/multiverse/config/sampleworld/sampleworld.mvw

startup_instance.py
Code:
#try hardcoding the path to the world file.  NEW: try again here now that servers are running under Cygwin
template.put(Namespace.INSTANCE, InstanceClient.TEMPL_WORLD_FILE_NAME, "c:/multiverse/config/sampleworld/sampleworld.mvw")
template.put(Namespace.INSTANCE, InstanceClient.TEMPL_INIT_SCRIPT_FILE_NAME, "c:/multiverse/config/sampleworld/instance_load.py")

multiverse.sh
Code:
function start_world_manager () {

    AGENT_TYPE=wmgr
          ###ORIGINAL    AGENT_NAME=$(alloc_domain_name AGENT ${AGENT_TYPE}_# )
  # Hardcoded because of invalid $AGENT_NAME, .pid file and log4j .out file error
    AGENT_NAME="wmgr_1"


multiverse.sh
Code:
function start_proxy () {

    AGENT_TYPE=proxy
      ###ORIGINAL    AGENT_NAME=$(alloc_domain_name AGENT ${AGENT_TYPE}_# )
    #Hardcoded because of invalid $AGENT_NAME, .pid file and log4j .out file error
    AGENT_NAME="proxy_1"


Still have to work out the path variables for the hardcoded stuff, for the other world files etc.
At least it's running for now.

You can hardcode the paths for all the .mvw in startup_instance.py and they work.

Hopefully this can help someone else who's having trouble getting this up and running.


On to the next challenge(s).


Back to top Go down
Guest
Guest



PostSubject: Updated   Sat 4 Aug - 6:15

Back to top Go down
Sponsored content




PostSubject: Re: Does Server Version 1.5 actually work on WinXP? YES. Connected   

Back to top Go down
 
Does Server Version 1.5 actually work on WinXP? YES. Connected
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» 2.2.0(7272)
» Proxy Server Taiwan: How To.
» Version 1.6 update
» Cross-Realms. Which Server can you Invite from and To?
» Improve your ping in China even to EU/US/Taiwan server

Permissions in this forum:You cannot reply to topics in this forum
 :: Development :: Getting Started-
Jump to: